Previous : Overview

Table of Contents

Next : Shortcut macros

 
What's New in GeoTools V5 - V12
GeoTools V5 GeoTools V6 GeoTools V7 GeoTools V9 GeoTools V10 GeoTools V11
GeoTools V12 GeoTools V13 GeoTools V14 GeoTools V15 GeoTools V16

 

What' new in GeoTools V8.00:
( Includes all changes since the last update of GeoTools V7 [i.e. 7.19] )

GeoTools V8.01 is the first version of GeoTools to be compatible with AutoCAD 2008.

 

New commands added in GeoTools V8.00

GT_XYZSCL command: GeoTools -> Miscellaneous Tools -> Scale objects unequally in X, Y and Z directions

GT_MEANPOINT command: GeoTools -> Miscellaneous Tools -> Create a mean (averaged) point from cluster of points

GT_EDGEBUILDER command: GeoTools -> Build Tools -> Build common edges along closed adjacent polygons

GT_GENSET  command: GeoTools -> Settings

GT_OD_STRUCEXT command: GeoTools -> AutoCAD Map Tools -> Extract object table structure to a text file

GT_SLOT  command: GeoTools -> Draw Tools -> Draw slot


(GEO) command: GeoTools -> Miscellaneous Tools - Enter the coordinates of point in geographic format [Lat-Long]

GT_CREATETAPER  command: GeoTools -> Draw Tools -> Taper lines

GT_ANNOTPOINTS command: GeoTools -> Annotation Tools - Annotate points based on layer names

GT_INTERSECT command: GeoTools -> Polyline Tool Set 2 -> Mark intersection points along lines, polylines and arcs  

GT_DANGLECHECK command: GeoTools -> Drawing Cleanup Tools -> Check for free ends (Dangles) of lines, polylines and arc's

GT_VISIT command: GeoTools -> Inquiry command -> Visit (Interactive pan) selected objects

GT_DATESTAMP command: GeoTools -> Text Tools -> Create Date/Drawing Stamp

GT_TUBE command: GeoTools -> Draw Tools -> Draw Tube

GT_PTINTERMANUAL command: GeoTools -> Build Tools -> Interpolate point elevation from neighboring polyline - manual pick

GT_PTINTERAUTOMATIC command: GeoTools -> Build Tools -> Interpolate point elevation from neighboring polyline - automatic 

GT_FLIPZ command: GeoTools -> Miscellaneous Tools -> Flip (reverse) elevations (z) from selected objects

GT_JUNCTION command: GeoTools -> Polyline ToolSet 2 -> Mark junction points in a network of linear objects

GT_SHEETINS command: GeoTools -> Civil Tools -> Create and place Map sheet index block

GT_ANNOGRID command: GeoTools -> Civil Tools -> Create map grid

GT_TRUNCCONE command: GeoTools -> Draw Tools -> Draw a Truncated Cone



Commands enhanced or changed

----

GT_DENSIFY command: (Polyline Toolset 1 - Densify vertices): A number of bugs have been fixed in this version. A check has been added while processing polyline whose total length is less than the Segment length to be densified. This prevents the program from crashing out when encountering polylines whose total length is less than the segment length to be densified. The Densify algorithm has been replaced with a more advanced one and the program now accepts polylines with arcs also. Until now, you could use the GT_DENSIFY command on polyline without arc segments only. This limitation has been removed now.

GT_INTEX command: (Cleanup Tools - Intersections processor): A major overhaul has been done on this command. The 'Object Break Options' have now been implemented. You can now split a network of inter-connected lines into individual segments at each point where they intersect by enabling the 'Object Break' options. Until now, it was only possible to add interpolated vertices at the intersections but not break the polylines at these points.

GT_GENSET command: (GeoTools->Settings): A new 'Settings' option has been added here called 'Fuzzy search distance around points of interest'. This is a generic search distance parameter used in GeoTools commands when a search is required to be made around a point of interest for the existence of other 'very closeby' objects. For example, whiile searching to find if there is another polyline starting (or passing by) the ends of a polyline, you would need to apply different search distances, depending on whether your AutoCAD units are survey units like meters or feet -OR- if they are geographic units like Latitude and Longitude. While in the former case, a value like 0.01 is an acceptable search distance, in the latter case, it should be a very small value like 0.0000001. The provision of this parameter under GeoTools->Settings allows you better control of your processing needs, especially when you have to deal with geographic as well as map projection units in AutoCAD.

GT_ATT2OD command: (AutoCAD Map Tools - Transfer Block attributes to object data): This command has been made more flexible. A new option has been added to process blocks which have similar matching attribute tag names even if the block
names themselves are different. Enabling this option allows two or more differently named blocks with similarly named attribute tags to be used for the transfer of attributes to object table data. Disabling this option causes the command to work exactly like
how it was until now and only blocks matching the specified name AND tag would be selected for the transfer process.


GT_PL_STAT command: (GeoTools->Polyline toolset 2 -> Provide detailed polyline statistics): While generating the polyline statistics table the text height was taken from GeoTools general settings but now enhancement has been done by providing a text height box in the command user interface itself so that user need not have to go and set the text height each time in general settings.

General enhancement:
A general selection enhancement has been made to all applicable GeoTools commands. When any GeoTools dialog box offers a choice of variable number of items to select in a list box (like block names, object table names, field names, drawing names, application names etc), the command in question will automatically select and highlight the sole entry in the list box of the dialog if there are no more than one entry. This has been made under the premise that if there is only one entry to select, that must be, most likely, the only entry you will need to select as there are no other choices. GeoTools now does this intelligent guess-work for you and pre-selects it. If the list box has multiple entries for selection, then it works like before and no pre-selection highlight is made. Instead, you have to select the required entries yourself.

GT_OD_LIST command: (AutoCAD Map Tools - List object table data): The GT_OD_LIST command has been enhanced. You now have an option to capture the object data listing entity-wise into an ASCII text file in addition to listing it on screen. Additionally, the formatting of the object data has been made more clearer so that it is more readable now.

GT_ENCLOSE command: (Text Tools - Enclose text in box, circle or slot):
The GT_ENCLOSE command is enhanced to enclose the text in a slot also, previously it was enclosing the text in a box or circle but now it is enhanced to enclose the text with slot also.

GT_AUTOPAN command: (Draw Tools and Polyline Toolset 3 -  Draw 2d/3d polyline with auto-edge panning):
The GT_AUTOPAN command is enhanced to draw 2d/3d polylines with geographic unit i.e. in Latitude and longitude format (for example, 33 01' 53.8739",18 01' 11.2246",480.0) is a Latitude of 33 01' 53.8739" and a Longitude of 18 01' 11.2246" and a height of 480.0.

GT_OD_EXTRACT command: (AutoCAD Map Tools - Extract object data to ASCII file): The GT_OD_EXTACT command has been considerably enhanced. You now have an option to write the field names in the output as the first line record (header record).

GT_BLKEDIT command: (Block tooks - Edit blocks graphics and attribute properties independently): The GT_BLKEDIT command has been enhanced. An additional block selection option has been provided. It is now possible to select the block to edit by picking it directly from the drawing rather than by selecting from the drop-down list. This makes it easier to select the blocks to edit by way of a visual pick selection.

GT_SEGLABEL command (Annotation menu -> Label polyline segments): Two new segment annotation options have been added to this command. You can now label the segments by sequential running numbers, as well as by means of an arrow depicting the direction of slope (Upwards or Downwards) computed between the two vertices of the segment in question. Do not confuse this with the 'Slope' annotation option called 'Direction'. The Slope option called 'Direction' is a text based annotation which prints "Up", "Down" or "Horiz" depending on the segment orientation. The new option that we have added now is labelled "Arrows in Elevation Direction [Up->Down]" and "Arrows in Elevation Direction [Down->Up]", and uses arrow marks pointing in the specified direction, to indicate the segment direction as against using a text label.

G
T_ANNOTPOINTS command (Annotation menu -> Annotate points based on layer names): Two new annotation options have been added to this command. You can now optionally specify a different annotation layer, whose name is derived based on a user-defined suffix added to the points layer-name. So, if the points are on layer 'POINTS' and if the suffix is '_TXT', the annotation will be placed in the 'POINTS_TXT' layer. The second new option is to provide an X and Y offset to the text being placed. This will position the text away from the points fro clarity purposes.

GT_REM_LINVERTS command (Polyline Tool Set -1  -> Weed (remove) collinear vertices from polyline): The GT_REM_LINVERTS command is been enhanced to mark points at the location where the vertices have been removed. A dialog box will be prompted at the start of the command asking you to select whether to mark points at the location where the vertices have been removed.

GT_Createcentroid command (Polyline Tool Set -3 Draw centroiad marks inside closed polylines):  The text height while marking the centroid with running number text or fixed text string was controlled from GeoTools general settings but now a text box is provided for entering the text height for marking the centroid with running number text or fixed text string. 

GT_DISTANGWEED command (Drawing Cleanup -> Weed [remove] polyline vertices based on angle and distance):
The GT_DISTANGWEED command has been enhanced. It will now optionally create marker points at the locations of vertices which were weeded. This helps to analyze your data better and know exactly which points were removed during the weeding process. The marker points are created in a GeoTools temporary layer "GEOTOOLS_TEMP"

GT_DATESTAMP command (Text Menu -> Create Date/Drawing Stamp):
The GT_DATESTAMP command has been enhanced. It can now automatically update any existing date and drawing stamp in the drawing with the current date and current drawing name, if they are different. Please be aware that this automatic update of drawing and date stamp will work only with date/drawing stamps created with GeoTools version 8.09 and later. Date/Drawing stamps created with earlier versions of GeoTools cannot be automatically updated. Additionally, there is third annotation option called "Both". This will create a DateStamp and a Drawing stamp in one single operation.

GT_IMPEX command (Export Tools -> import/Export points/lines): The GT_IMPEX command has been enhanced. You can now optionally have the format as stacked coordinate fields (one per line). For example, if your input format is PENZD, you can now have P, E, N, Z and D in separate lines instead of being in one single line separated by a delimiter. You can also export your data as stacked coordinate fields. The stacked fields import and export is allowed only for point features and not for linear features.

GT_CCPOLY command (Polyline ToolSet 3 and Buid Tools -> create closed polylines from mass of network polyline ): The GT_CCPOLY command has been enhanced. You can now specify different scan methods i.e. automatic or at selected points and with in specified search (scan) limit. You can even select the layers for closed polylines and for polygon edges.  

GT_TC command (Text Tools -> Draw quick text (running numbers)): The GT_TC command has been enhanced. You now have the ability to insert a new counter text in an existing series of text objects and automatically update all the other texts in the series which match the criteria. For example, if you have a existing text series like A1, A2, A3, A4, A5 and so on, you can insert a new text object called A3 and the program will automatically renumber all existing text objects greater that the picked value , like A3 becomes A4 and A4 becomes A5 and so on.

GT_FILLETPOLY command (Polyline Toolset 3 - Enhanced Fillet command ): The command is now offered as a replacement for the standard AutoCAD fillet command, which has several short-comings. For example, the AutoCAD fillet command does not work correctly under the following situations:

a. Fillet between an ARC and a polyline object
b. Fillet between a LINE and polyline that has arc segments near the fillet end.
c. Fillet between an ARC and polyline that has arc segments near the fillet end.

The GT_FILLETPOLY command processes all of the cases in (a), (b) and (c) above successfully.


GT_3DOFFSET command (Polyline Toolset 2 and Build Tools - Offset 3D Polylines ): The GT_3DOFFSET command has been enhanced with an additional option called vertical offset. With this, you can now offset a 3d polyline both horizontally as well as vertically in the Z direction. This can be a very useful tool in several civil engineering situations where you want the ofsetted polyline to be elevated or lowered by a fixed amount relative to the source polyline.

GT_PL_DATALBL command (Annotation Tools - Label polylines with Object / Database linked database ): The GT_PL_DATALBL command now accepts multiple objects for annotation in addition to individual single picked annotations. If the 'multiple' option is chosen, all the objects will be annotated at their curve mid points.


Interface changes

----

Bug Fixes
----

GT_XP_ATT (Block Tools - Explode blocks, retain attributes as text): There was a bug in this command which affected AutoCAD 2007 version and above only. Upon exploding the blocks, the attribute values would not get re-cerated as text. This has now been fixed. The program now correctly re-creates all attributes correctly.

GT_PL_INTER (Polyline Tools - Assign interpolated Z values to vertices): The behavior of this command has been slightly modified. If the polyline is closed AND if the first vertex is a non-zero value, the program will now use this first vertex elevation value considering it as the non-zero elevation of the last vertex and perform linear interpolated for the last stretch of the polyline.

As an illustration, in a 7-vertex closed polyline, if the elevations of Vx1=2.5, Vx2=0.0, Vx3=0.0, Vx4=0.0, Vx5=8.5, Vx6=0.0, Vx7=0.0, then this version of the GT_PL_INTER will interpolate Vx6 and Vx7 linearly between the elevations of 8.5 and 2.5. In earlier versions, this would have been left as 0.0 and not interpolated.

GT_PARTOFFSET, GT_PARTMIRROR, GT_PARTCOPY, GT_PATSTRTECH (GeoTools -> Build Tools) commands: have been slightly modified: If a closed polyline was selected for the edit operation and if the first and next points of edit would be the last and first point (in that order) of the polyline, the program would select the remaining segments for processing. This has now been fixed. Yet another bug in the GT_PARTMIRROR and GT_PATSTRTECH command has been fixed. This bug was causing the last vertex of the polyline to be deleted during GT_PARTMIRROR and GT_PARTSTRETCH operations in earlier versions.

GT_GENSET command (GeoTools -> Settings): The default unit for linear measurements (used only in annotations) used to be set to "feet" by default, in earlier versions. And some commands like GT_CALCAREA, GT_SURFAREA etc would report areas in converted acres also, by default. This has been somewhat changed now in order not to be irrelevant and confusing to metric users of GeoTools. If the unit for linear measurement is set to "feet" or "ft", the acreage will be reported else if it is set to "meters", the acreage of areas will not be displayed. By default, the linear units for all English versions of GeoTools will default to "feet" first-time while in Spanish and German versions, it will default to "meters".

GT_LAYERMAN command: (Miscellaneous Tools - Layer Names Manager): The 'Search and Replace' of layer names has been bug-fixed and enhanced. The operation will now correctly report the layers which were renamed because of a 'Search-Replace' and also report on the layers that could not be renamed.

GT_MVOFFSET command: (Polyline Tool Set -3  Multiple variable polyline segment offset): The GT_MVOFFSET command was not allowing to exit until all the segments of polyline were offseted. This bug has been fixed.

GT_INOUTOFFSET command: (Polyline Tool Set -3  Offset multiple polylines inwards or outwards): The GT_INOUTOFFSET command now prompts a dialog box at the start stating to select only closed 2D polylines. 

GT_CGRAV command: (Inquiry Tools -  Find center of gravity): The GT_CGRAV command had a bug it was marking the center of gravity for open polylines also. Now this is been fixed if an open polyline is selected it checks and displays the message stating center of gravity cannot be determined for open curve.

GT_SPLITTEXT command (Text Tools -> Split long text strings into smaller individual strings): This command has been completely re-written with new, more efficient techniques and is now working correctly. We have tested this with several popular text styles and various text formatting options. Please be aware the the command produces best results when the text is left justified. With all other text justifications, it does split the text but the splitted components may not always align correctly at its original location. This is a known limitation and some amount of manual adjustment may be needed.

GT_CENTLINE (Build Tools -> Draw center-lines from roads R-O-W): Significant improvements and bug-fixes have been made in this command to improve operational stability.

GT_CHCASE command (Text Tools - Change case ):
The GT_CHCASE command was not working correctly on multi-line MTEXT objects when the case change option was either "Lower" or "Mixed-Case". This has now been fixed.

GT_CONS_TXT command (Text Tools - Consolidate text into Mtext ):
The GT_CONS_TXT command was not working correctly. It would remove the 'U' character from text strings if it happened to be the first character of the string. This has now been fixed.

GeoTools Tutorial

Lesson 1 - Polyline Tools
In this lesson we cover how to utilize polyline tools for converting the polyline from 2D to 3D and assigning 'Z ' values to it.

Lesson 2 - Polyline Editing and Annotation Tools
In this lesson we cover how to edit polylines and annotate them.

Lesson 3 - Block Tools
In this lesson we cover how to utilize some of the block tools for representing Lots and marking there centroid.

Lesson 4 - Text Tools
In this lesson we cover how to utilize some of the text tools for editing and modifying the text in the drawing.

Lesson 5 - Inquiry Tools
In this lesson we cover how to utilize some of the Inquiry tools for finding out the details of the Lots.

Lesson 6 - Annotation Tools
In this lesson we cover how to utilize some of the Annotation tools for Annotating the polylines.

Lesson 7 - AutoDesk Map and Xdata Tools
In this lesson we cover how to utilize some of the AutoDesk Map and Extended entity data tools for working with Object data and Xdata.

Lesson 8 - Conversion Tools
In this lesson we cover how to utilize some of the frequently required conversion tools in road development. 

Lesson 9 - Build Tools
In this lesson we cover how to utilize some of the Build tools used for road development and Frontage Clearance.

Lesson 10 - Block and Text Tools
In this lesson we cover how to utilize some of the Block and text tools for working with block attributes.

Lesson 11 - AutoDesk Map Tools
In this lesson we cover how to utilize some of the AutoDesk Map Tools on Object Table Data.

Lesson 12 - Block Tools for Exporting and Editing Attributes
This tutorial covers how to utilize some of Block tools for Exporting (extracting) and editing block attributes.


Previous : Overview

Table of Contents

Next : Shortcut macros