Previous : Overview

Table of Contents

Next : Shortcut macros

 
What's New in GeoTools V5 - V12
GeoTools V5 GeoTools V6 GeoTools V8 GeoTools V9 GeoTools V10 GeoTools V11
GeoTools V12 GeoTools V13 GeoTools V14 GeoTools V15 GeoTools V16

 

What' new in GeoTools V7:
( Includes all changes since the last update of GeoTools V6 [i.e 6.19] )

GeoTools V7 is the first version of GeoTools to be compatible with AutoCAD 2007.

 

New commands added in GeoTools V7

GT_CONTDIST command: GeoTools -> Miscellaneous Tools -> Contour Spacing Distance Tool

GT_CONTBREAK command: GeoTools -> Miscellaneous Tools -> Break (split) objects along a polyline

GT_BATCHPROCESS command: GeoTools -> Miscellaneous Tools -> Batch process multiple drawings with scripts

GT_SHOWXD command: GeoTools -> Extended entity Tools -> Display extended entity data from picked object

GT_XD_EXTRACT command: GeoTools -> Extended entity data tools -> Extract extended entity data to ASCII files

GT_XD_SEARCH command: GeoTools -> Extended Entity Data Tools -> Search and replace extended entity data

GT_DRAPEPOLY command: GeoTools -> Build Tools -> Drape 3d polylines over an set of intersecting objects
 
GT_FLATTEN command: GeoTools -> Conversion Tools -> Flatten - Convert to 0.0 elevation
 

GT_ZOOMENT command: GeoTools -> Miscellaneous Tools -> Zoom to extent of selected object(s) (with 5% margin

GT_EASYTEXT command: GeoTools -> Text Tools -> Create text aligned to a curve

GT_BOXSCREEN command: GeoTools -> Draw Tools -> Draws a rectangular box at the current screen extents

GT_BOUNDENT command: GeoTools ->  Draw Tools -> Draws bounding box around selected object(s)

GT_ISOD command: GeoTools -> Layer Tools -> Isolate layers

GT_RESTORE command: GeoTools -> Layer Tools -> Restore isolated layers

GT_SL1 command: GeoTools -> Layer Tools -> Save layer state - 1

GT_SL2
command: GeoTools -> Layer Tools -> Save layer state - 2

GT_SL3 command: GeoTools -> Layer Tools -> Save layer state - 3

GT_RL1 command: GeoTools -> Layer Tools ->Restore layer state - 1

GT_RL2 command: GeoTools -> Layer Tools -> Restore layer state - 2

GT_RL3 command: GeoTools -> Layer Tools -> Restore layer state - 3

GT_COPYLYR  command: GeoTools -> Layer Tools -> Copy layer contents to another layer

 


Commands enhanced or changed


GT_VEGLINE (Miscellaneous / Draw Vegetation Cover Symbols) :  A bug has been fixed in this command. It now handles cover symbol generation along the curved portion of an arced polyline correctly. Earlier versions would just create the vegetation symbol between the two end-points of the arc and not along the curve.

GT_OD_EXTRACT (Autodesk Map Tools - Extract Object Table Data to ASCII files): The GT_OD_EXTRACT command was not exporting the 'Additional Export Options' of ObjectName, Layer Name and handle correctly in the export, if these options were checked and on. This has now been fixed.

GT_PROFILE (Civil Tools - Draw cross-sectional profile from 3d polylines): Two new options have been added to this command. You can now annotate along with the profile the X and Y coordinates of the profiled point. In addition to the chainage, elevation, named sections etc, you can now optionally add the X and Y coordinates as well in the annotation. The X and Y coordinates are exported into the profile chainage description text files, now you can display them in the drawing as well.

 GT_CONTLABEL ( Polyline Tool Set 1 & Annotation Tools menu) : The GT_CONTLABEL command ( Polyline Tool Set1 & Annotation Tools menu) command can now accept multiple lines and polylines as input for the "At Cutting lines location"
option. Earlier versions would allow the user to pick a single line or polyline and generate the contour labels at all intersections along this line. You can now select multiple lines and polylines instead.

 GT_ASN_PROP ( Conversion Tools - Inherit properties from neighbouring objects) : The GT_ASN_PROP command has been enhanced with two new options. You can now prevent the command from processing one neighboring text/insert object more than once. This will often result in more accurate processing by eliminating the possibility of two different points or vertices acquiring the elevation / thickness property from the same object. There is also another option added which to optionally delete each text/insert from the drawing as they are processed.

GT_P2BLKSHP ( Conversion Tools - Convert points to Blocks/Shapes) : This command now allows you to set the rotation angle and scale factor of the blocks or shapes within the GT_P2BLKSHP dialog itself. You no longer have to do so by modifying the GeoTools global settings. It is our medium to long-term goal in GeoTools to provide localized settings for common user parameters like Scale Factor, Text Size, Rotation and not depend on the global GeoTools settings.

GT_BREAKX (Polyline Tool Set 1 - Break crossing objects at ends): This command will now retain both extended entity and object table data in the broken part. The earlier version would retain the extended entity data but not object table data.

GT_DRAWGRADE ( Civil Tools - Draw graded polylines ): The GT_DRAWGRADE command now has an option to specify the grade in terms of degrees (inclination) from the horizontal. In other words, you can now easily draw 3d polyline segments which are inclined at a specified angle from the XY plane. You can also place annotations based on degrees from horizontal, in addition to the existing options of Slope(%) and 1:n notations.

GT_PL_PLACE (Polyline Tool-Set 1 -> Place points/blocks along polyline vertices): This command now allows you to set the rotation angle and scale factor of the blocks within the GT_PL_PLACE dialog itself. You no longer have to do so by modifying the GeoTools global settings. It is our medium to long-term goal in GeoTools to provide localized settings for common user parameters like Scale Factor, Text Size, Rotation and not depend on the global GeoTools settings.

GT_VXLABEL (Polyline Tool-Set 1 -> Label Vertices): This command now allows you to set the text height and rotation angle within the GT_VXLABEL dialog itself. You no longer have to do so by modifying the GeoTools global settings.

GT_SEGLABEL (Polyline Tool-Set 1 -> Label Segments): This command now allows you to set the text height within the GT_SEGLABEL dialog itself. You no longer have to do so by modifying the GeoTools global settings.

GT_TC (Text Tools -> Draw Quick Text (Running Numbers)): This command now allows you to set the text height within the GT_TC Settings dialog itself. You no longer have to do so by modifying the GeoTools global settings.

GT_MT (Text Tools -> Draw Multiple Text) : This command now allows you to set the text height within the GT_MT dialog itself. You no longer have to do so by modifying the GeoTools global settings.

GT_PL_STAT (Polyline ToolSet 2 - Compute detailed polyline statistics): Additional polyline statistics like maximum, minimum and average segment length have been added to the list of statistics generated from a polyline.

GT_PLINE2ARC (Polyline ToolSet 3 & Conversion Tools - Convert linear polylines to arcs): The GT_PLINE2ARC command
has been enhanced with a new option which allows each segment of the polyline to be represented by an arc segment as opposed to the earlier options which allow arcs to be created based on the polyline vertex points. To give you some useful applications of this command, the GT_PLINE2ARC command is useful to prepare data for many CNC applications where you need to provide the input as arc instead of polyline geometry.


GT_P2BLKSHP ( Conversion Tools - Convert Points/Text/Circles to Blocks/Shapes ) and GT_BLKSHP2P (Convert
Blocks/Shapes/Text/Circle to Points) have been enhanced. Both commands will now transfer any existing extended entity data as well as object table data while doing the conversion.

Interface changes

Changes to the Polyline Tools Menu: The complete collection of Polyline Tools has now been split up into three easily
manageable cascading sections, called Polyline ToolSet 1, Polyline ToolSet 2 and Polyline ToolSet 3. It is now much easier to browse and access the polyline tools than before.  This follows the exact sequence of the tools in the three 'Polyline Tools' icon toolbars. The order of tools in the pull-down menu, toolbars and the GeoTools documentation also has been synchronized and set in correct order. We hope this would make your experience of relating the different user interfaces and the documentation easier.


Changes to the online user manual: The user manual has been completely re-designed and is now a CHM file for easy access and management.

Bug Fixes

GT_PROFILE (Civil Tools - Draw cross-sectional profile from 3d polylines): The "Horizontal" distance measurement option now works correctly. Until now, it was not working correctly and the program would always use the "Slope Distance" measurements even if the "Horizontal" distance option was selected. This was a bug in the user-interface (dialog box) component and has been fixed.

GT_TXTFILTER command (Text Tools - Filter Text objects): User interface response, some bugs were fixed here.

GT_SHOWXD (Extended entity Tools - Display extended entity data from picked object): The listing of xdata from the picked object is made more user-friendly and prettier. The old style xdata struucture dump is also retained as it is for those of you who want to explore the structure in its raw form.

GT_MVEDIT (Polyline ToolSet 3 - Multiple vertex editor): A bug has been fixed in the "Move Vertex By Pick" option. This would earlier cause the program to crash with a "too many arguments" error.

GT_CHOP (Miscellaneous Tools - Object Chopper): Some bugs have been fixed in this command. It now chops into number of segments of length/segment correctly.

GT_ASN_PROP (Assign inherited properties) : A bug has been fixed in this command.

GT_DENSIFY (Polyline TolSet 1 - Densify Vertices): This command is being completely re-written. It now displays the same kind of We regret the inconvenience caused but it has been disabled in this version for maintenance and will be up and running in the next update of GeoTools.

GT_IMPEX (Export Tools - Import/Export points & lines): A bug has been fixed in this command. You can now have import text files having more than the required number of fields. For example, in earlier versions, if you had chosen PENZD as the import format, you should have had exactly 5 fields (and no more) in the import file. Now you can have additional fields trailing the required number of fields and the program will ignore than and process the required ones.

GT_FLIP ( Polyline Tool Set 1 - Flip (reverse) polylines) : A bug has been fixed in this command. It will now flip polylines with non-zero elevations correctly.

GT_P2BLKSHP ( Conversion Tools - Convert Points/Text/Circles to Blocks/Shapes ): This command was not able to run in batch / script mode. This has been fixed now.

GT_CCL (Change to current layer) and GT_CPCL (Copy to current layer): These two command were not earlier named as CCL and CPCL. This has been fixed now and the command names are now GT_CCL and GT_CPCL. And, these commands have now also been added to the pull-down menu and toolbars, in addition to being available on the command line.


Previous : Overview

Table of Contents

Next : Shortcut macros