Previous : Overview

Table of Contents

Next : Shortcut macros

What's New in GeoTools V5 - V12
GeoTools V5 GeoTools V7 GeoTools V8 GeoTools V9 GeoTools V10 GeoTools V11
GeoTools V12 GeoTools V13 GeoTools V14 GeoTools V15 GeoTools V16

 

What' new in GeoTools V6:
( Includes all changes since the last update of GeoTools V5 [i.e 5.40] )


New commands added in GeoTools V6

GT_XP_RETDAT command: GeoTools -> Miscellaneous Tools -> Explode objects, retain object data and extended entity data

GT_GEO_INS command: GeoTools -> Miscellaneous Tools -> Add geo-referenced images


GT_SPLITTEXT command: GeoTools -> Text Tools -> Split long text strings into individual strings


GT_DRAWPOLYINCRDECR command: GeoTools ->  Draw Tools -> Draw 3d polylines with automatically incrementing / decrementing elevations

GT_ASS_EL_TEXT command: GeoTools -> Conversion Tools -> Assign contour polyline elevations from text objects

GT_CmdDlgTog (Only on command line) 

GT_CmdDlg (Only on command line) 



 

Commands enhanced or changed


GT_FLIP : [Polyline Tools - Flip (reverse) directions] :
Two new options have been added to this command. You can now flip polylines based on the values of the first and last point elevations. Depending on whether the first point elevation is lesser than or greater than the last point elevation, you can reverse the direction of the polyline. This is a very useful tool in many surveying and mapping applications where you expect polylines to be flowing in either increasing or decreasing z values. This command helps to identify such flows and reverse them. Please be aware that this tool only looks at the first and last point elevations and does not check the intermediate vertex elevation values for any reason.

In the future, we plan to come up with a more "intelligent" polyline elevation analyzer program that would also study the pattern on intermediate elevations and check if there are intermediate segments that violate the desired flow of the vertices.

GT_3DOFFSET : [Polyline Tools - 3d offset of polylines] :
The internal mechanism of this command has been altered slightly to overcome some bugs which would show up while handling some situations of 3d polyline vertices. The program is now more stable and error-proof. These changes affect only the handling of offsets when the number of vertices between the source and offsetted polylines are not the same.

GT_REPBLK : (Block Tools - Replace blocks) :
The GT_REPBLK command now allows a manual selection of blocks to be made for block replacement. The earlier way of working would replcae every instance of one block with another. This has now been changed. Additionally, this command now retains both extended entity data as well as object table data while replacing one block with another.

GT_SCALE_Z (Miscellaneous Tools - Scale Z elevation values):
This command now has its edit box width increased to 8. So, you can add more number of digits to the precision of the values that you are scaling.

Common enhancements:
GT_LINE2PL : (Polyline/Conversion Tools - Convert lines and arcs/circles to polyline):
GT_3DF2PL : (Conversion/Polyline Tools - 3DFaces to polylines)
GT_3DF2PFACE : (Conversion Tools - 3DFaces to polyface mesh)
GT_PFACE2PL : (Conversion Tools - Polyface mesh to polylines)
GT_CH3D2D : (Polyline Tools - Convert 3D-to-2D polylines)
GT_CH2D3D : (Polyline Tools - Convert 2D-to-3D polylines)
GT_XP_RETDADT: (Miscellaneous Tools - Explode objects, retain Xdata and object data)
GT_REPBLK : (Block Tools - Replace Blocks)

All of the above commands have been enhanced to retain both extended entity data and object table data while entities are transformed from source to target.

GT_OD_SEARCH (Autodesk Map Tools - Search and replace Object Table Data):
The GT_OD_SEARCH command now has an option to just do the Search without the Replace.

There is a new option called 'Replace Values' which, if checked, performs a search and replace operation. If it is not checked, only a search is performed and the objects meeting the search criteria will be placed in the active selection set. Some other bugs in this command have been fixed.

GT_XP_RETDAT : (Miscellaneous Tools - Retain object table data and extended entity data):
The GT_XP_RETDAT command has now been enhanced and it can now explode REGION objects and retain their object data and extented entity data in their exploded polyline form.

GT_IMPEX: (Export Tools - Import/Export points and lines) - The GT_IMPEX command now has additional options to handle exporting of linear features.

The following enhancements to the GT_IMPEX command have been done in this update:

1. You can now optionally create a blank line between two line/polygon records
2. You can now optionally use a different last point elevation identifier for line/polygon records. If this option is checked, the last elevation of each line or polyline record will have a different elevation string as entered in the edit box below. This feature is provided because some systems identify the end of a line/polyline by reading a special value set in the elevation field of the last point.
3. You can now overwrite an existing output file or simply append to it.

Progress Indicator Interval : Often, GeoTools displays a progress indicator by way of an informative message on the command line that indicates how many objects have been processed and how many are remaining to be processed.

Until now, the progress indicator message was updated for each object that was being processed. This can be quite time-consuming when large data-sets have to be processed and it takes up significant computing time. To overcome this, we are introducing a parameter called 'Progress Indicator Interval' in the General Settings dialog box (GT_GENSET command).
Here, you can now specify the progress indicator interval you want. So, if you specify 100 as the interval, the progress indicator will refresh itself only once each 100 objects are processed. This speeds up processing significantly.

GT_ASN_PROP: (Assign inherited properties from neighboring objects - Conversion Tools) : The GT_ASN_PROP command can now assign to each vertex of a 3d polyline elevation values inherited from neigbouring text or block attributes.

GT_MODTXT: (Globally Modify Text/MText objects): This command now has an added option to trim characters from the beginning or end of a string of text/mtext upto a specifed marker character. The marker character should be a single character that has to be specified in the object edit box labelled "Enter value for selected property"

Bug Fix & Enhancement : GT_DENSIFY : The GT_DENSIFY command has now been bug fixed and updated. The command now correctly interpolates the in-between added vertices and it acquires 3d elevations correctly by interpolation.

There have been some minor changes in the program options. The option to measure distances by 'Slope' or 'Horizontal' has been removed and the program now measures in Slope only. The option to "Interpolate" 3d polyline vertices has been removed and interpolation is now automatic for 3d polylines.

 

Bug Fixes

GT_NEWSTART : (Polyline Tools - Specify a new start for closed polylines) :
The GT_NEWSTART command has a small bug fixed. Whether the polylines had an explicit closing vertex duplicated as first vertex or not (implicit closing), the same structure is now carried forward to the new polyline with its modified start point. Earlier, no matter what the original polyline was, the new polyline had its last point duplicated explicitly as the first point.


Previous : Overview

Table of Contents

Next : Shortcut macros