Previous : Overview

Table of Contents

Next : Polyline Tools

 
What's New in GeoTools V5 - V16
GeoTools V5 GeoTools V6 GeoTools V7 GeoTools V8 GeoTools V9 GeoTools V10
GeoTools V11 GeoTools V12 GeoTools V13 GeoTools V14 GeoTools V15



What' new in GeoTools V16
( Includes all changes since the last update of GeoTools V15 [i.e. 15.22] )

GeoTools V16 is compatible with AutoCAD versions 2007-2016 and BricsCAD V15, V14 and V13.

 

New commands added in GeoTools V16


 

Commands Enhanced or changed

GT_SLOPEDISPLAY (GeoTools -> Civil Tools -> Color-coded slope display of TIN faces) : The default slope values in percentages was limited to a range from 0% to 100% (45 degrees slope). This resulted in not being able to display slopes greater than 45 degrees. This has been fixed. The slope ranges have now been increased to 2000% which is a 87 degree slope, perhaps the maximum you can encounter in real life.

GT_PROFILE (GeoTools -> Civil Tools -> Draw cross-sectional profile from 3D Polyline): 

  • Chainage output file format changed to CSV to facilitate easy export to Excel. A comma is now used as a delimiter (instead of fixed field length space delimiters earlier) for the same reason. 
  • The chainage output file format has changed slightly. A new field called 'SerialNumber' has been added to track count of the records. The 'Height' field has been moved to the end, after Easting and Northing. Incorrect profile layer classification bug fixed.

GT_CHAINAGE (GeoTools -> Civil Tools -> Annotate chainages along a route): Improvements have been made in this command. The entire chainage data information is now written to CSV file which can import into Excel directly.

GT_SCALE_Z (GeoTools -> Conversion -> Scale Z values): This command now accepts 3dface objects also for Z scaling.

GT_PL_STAT (GeoTools -> Polyline Tools -> Inquiry Statistics -> Compute detailed polyline statistics): The name of the default output file has been changed from PL_STAT.txt to <drawing_name>_PL_STAT.csv to relate the output with the drawing and import into Excel easily.

GT_TRIANGULATE (GeoTools -> Civil Tools -> Create TIN (Delauney triangulation)): The GT_TRIANGULATE command can be slow when working with large datasets. There is now an effective workaround to handle large datasets. If the number of points selected is more than 1000, this tool will now give you the option to process the TIN in parts. Simply specify the number of square areas into which you want to split the entire area and the TIN will be processed part by part but the net end result is pretty much the same. With this new feature, you can now process hundreds of thousands of points in just a few minutes.

GT_SLOPEDISPLAY (GeoTools -> Civil Tools -> Color-coded slope display of TIN faces): The GT_SLOPEDISPLAY command has been enhanced significantly. It now computes slopes in degrees also, in addition to percentage slopes. It will also create a slope table which lists the slope ranges, their colors and the area under each slope. There is also an option to export the slope table into a CSV file.

GT_POINTWEED (GeoTools -> Drawing Cleanup -> GT_PointWeed): The precision values for the search window is now set as per the current linear units precision.

GT_CMDHELP (GeoTools -> More Options -> Specific Command Help): GeoTools & CADPower are companion products that work in concert. If you enter the name of a command in one product and if it does not exist, it is searched for in the other product and displayed if it exists there. This ensures that the user can locate the command in either software and get help from one single place.

GT_TRIANGULATE (GeoTools -> Civil Tools -> Create TIN (Delauney triangulation): The GT_TRIANGULATE command has been enhanced significantly:

  • Reporting has been improved:A message now advises users to identify and fix data with identical XY values but differing Z values which can cause a crash. This ensures better performance, predictable results and prevents crashes due to data errors.

  • A bug has been fixed in the 'Parts' option that computed the Y interval incorrectly.

  • A bug has been fixed in the 'All' option that caused a crash (regression bug introduced in 16.02)



Interface changes

----

Bug Fixes
----

GT_CCPOLY (GeoTools -> Build -> Create closed polylines from a mass of networked polylines): Polygon edges selected was shown in the dialog box as a line item but not remembered in the layer dialog. This has been fixed now.

GT_CROSSSECT (GeoTools -> Civil Tools -> Multiple Cross Section Tools): The layer for 'TIN Triangles' and '3dprofiles' selection are not updating correctly. This has been fixed now.

GT_LENTEXT (GeoTools -> Annotation -> Create/update length annotation): The dialog box settings were not saved in memory for the next session until the command completed its operation. This has now been fixed. Upon exit from the 'Settings' dialog box with an 'Ok', the settings are immediately saved in the registry.


GeoTools Tutorial


Previous : Overview

Table of Contents

Next : Polyline Tools