Previous : Overview

Table of Contents

Next : Polyline Tools

 
What's New in GeoTools V5 - V14
GeoTools V5 GeoTools V6 GeoTools V7 GeoTools V8 GeoTools V9 GeoTools V10
GeoTools V11 GeoTools V12 GeoTools V13 GeoTools V15 GeoTools V16



What' new in GeoTools V14
( Includes all changes since the last update of GeoTools V13 [i.e. 13.12] )

GeoTools V14 is compatible with AutoCAD versions 2007-2014 and BricsCAD V14 and V13.

 

New commands added in GeoTools V14

The new Geographic menu in GeoTools adds a number of geographic functions.

GT_COORDTRAN: GeoTools -> Geographic Tools -> Coordinate Transformation 

GT_COORDTRAN_SETUP: GeoTools -> Geographic Tools -> Coordinate Transformation Setup

GT_DWG2KML: GeoTools -> Geographic Tools -> DWGKML - Interactive

GT_DWG2KML_BATCH1F: GeoTools -> Geographic Tools -> DWGKML - Batch  Feature

GT_DWG2KML_BATCHMULTF: GeoTools -> Geographic Tools -> DWGKML - Batch  Multiple Feature

GT_INSPHOTO:  GeoTools -> Geographic Tools -> Insert a geo tagged photo

GT_CHECKUPADTES: GeoTools -> More Options -> Check for Updates

GT_DEBUGINFO: GeoTools -> More Options -> Debug Info

GEOL_BOREHOLELOGGER: GeoTools -> Geological / Mining Tools -> Import bore hole data

GT_GENSET: GeoTools->Settings -> Force reload of CUI at startup

GT_CMDSEARCH: GeoTools -> More Options -> Search GeoTools / CADPower Commands

GT_CMDLIST GeoTools More Options List GeoTools/CADPower commands

GT_EXTRACTGMLFEATURES: GeoTools -> Export -> Extract individual GML features from GML file

GT_READGMLFEATURES: GeoTools -> Export -> Import a single GML feature from file

GT_SLOPEDISPLAY (GeoTools -> Civil Tools -> Color-coded slope display of TIN faces)

GT_FINDSLOPE (GeoTools -> Civil Tools -> Find slope of a single 3dface or 3dpolyline)


 

Commands Enhanced or changed

Minor enhancement: Many GeoTools commands offer dialog boxes within them that allows selection from a list of available choices. When the choices are many, selecting exactly what you need is cumbersome. A new 'Filter' option has been added to allow wild-card based filtering of what you see in the dialog box. The 'Filter' option will make data selection and management of data easier. This dialog is used by several commands to select layers, blocks, CAD styles, object types and user-created data from the DWG.

GT_POINTWEED: (GeoTools -> Drawing Cleanup -> Weed points based on spacing): This command now reports the number of points deleted during the weed process, giving a clearer message to the user.

GT_BREAKX (GeoTools -> Drawing Cleanup -> Break crossing objects at ends): This command now accepts line objects as input, in addition to polylines.

Interface changes

----

Bug Fixes
----

(geo) (GeoTools -> Miscellaneous Tools -> Enter geographical coordinates-Latitude,Longitude,Height): This command was broken and has been fixed.

GT_TRIANGULATE command (GeoTools -> Civil Tools -> Create TIN (Delauney triangulation)) would crash if it found two DTM points that were duplicated and at the same location. This has now been fixed.

The automatic loading of toolbars during startup of CADPower and GeoTools has been disabled. The feedback we got was that this was annoying and must be removed.

GT_IMPEX command: (GeoTools -> Export -> Import/Export points and lines): This command had a bug resulting in incomplete and wrong processing during import if the description field contained leading or trailing spaces. This has now been fixed.

GT_INSPHOTO: GeoTools -> Geographic -> Insert GeoTagged photo: There was a problem with the PHOTO-CIRCLE.dwg block supplied with GeoTools. It was a 2013 dwg format and could not be opened in earlier versions of AutoCAD. This has now been fixed, and the DWG is now shipped as a R2000 dwg.

 

GeoTools Tutorial


Previous : Overview

Table of Contents

Next : Polyline Tools