Previous : Overview

Table of Contents

Next : Polyline Tools

 
What's New in GeoTools V5 - V12
GeoTools V5 GeoTools V6 GeoTools V7 GeoTools V8 GeoTools V9 GeoTools V10
GeoTools V11 GeoTools V13 GeoTools V14 GeoTools V15 GeoTools V16



What' new in GeoTools V12
( Includes all changes since the last update of GeoTools V11 [i.e. 11.20] )

GeoTools V12 is the first version of GeoTools to be compatible with AutoCAD 2012.

 

New commands added in GeoTools V12

GT_EASYATTCLASS command: GeoTools -> Block Tools ->  Change block layers/color based on attribute values

GT_DYNATTPLACE command: GeoTools -> Block Tools -> Place blocks /attributes position interactively

GT_VIEWLINKED command: GeoTools -> Export Tools -> View Handle-Linked Objects

GT_UPDATEPOINTBLK command: GeoTools -> Block Tools -> Update 'Coordinates Block' attributes

GT_PROP2ATT command: GeoTools -> Block Tools -> Transfer AutoCAD properties to block attributes

GT_TXTEVAL command: GeoTools -> Text tools -> Apply arithmetic/statistical operations on text objects

GT_HATCHAREA command: GeoTools -> Miscellaneous Tools -> Report areas covered by HATCH objects

GT_DELETELAYOUTS command: GeoTools -> Miscellaneous Tools -> Delete paper-space layouts

GT_NIKON2DWG command: GeoTools -> Export Tools -> Import a NIKON survey device raw file

GT_CROSSSECT command: GeoTools -> Civil Tools -> Compute volumes across multiple cross-sections

GT_FLIPARCS command: GeoTools -> Miscellaneous Tools -> Flip ECS of arcs with negative normals

GT_DELSVP command: GeoTools -> Polyline ToolSet 2 -> Delete Single vertex Polylines

GT_BEARINGDIST command: GeoTools -> Civil Tools -> Bearing and Distance

GT_NEWBCSKIN command: GeoTools -> Change BricsCAD skin

GT_SLOPEDISPLAY command: GeoTools -> Civil -> Slope display of TIN Triangles

GT_EASYEED command: GeoTools -> Extended Entity Data -> View / Edit Extended entity data

 

 

 

 

Commands Enhanced or changed

1. GT_COMPAREBLKATTS (GeoTools Block Tools Compare Block attributes and create report)
The GT_COMPAREBLKATTS command has been enhanced.
Until now, it was only capable of creating a report of block names in the drawing having identical tag names. It can now create a report of block attributes that have similar block attribute values as well. In other words, if you need a report of block attributes with unique values (number of such occurences), this is the tools to use.

2. GT_DELVX (GeoTools Polyline ToolSet1 Delete Vertex) : An 'Undo' option has now been added to both these commands which will allow you to undo each operation of vertex insert or delete without having to undo or redo the whole command.

3. (geo) (GeoTools Miscellaneous Tools More Enter geographical coordinates-Latitude,Longitude,Height): (geo) is a transparent function that can be used to input a geographic point. You can now input the latitude or longitude locational qualifiers like N, S, E and W following the value. For example, 55N 23 21, 25E 12 23,0.0 is now a valid input. N and E qualifiers are taken as positive coordinates, S and W qualifiers are taken as negative coordinates. Accordingly, the sign of the coordinates become positive or negative. Earlier, you had to specifically give a negative (-) sign in front of the value to denote the negative. This method is still supported.

4. GT_GEO_INS (GeoTools Miscellaneous Tools Insert a geo-referenced image): A bug has been fixed in this command which was causing a malfunction in the past few updates of GeoTools V11. Minor enhancements have been made in the default folder naming convention. The location for the 'World files' folder is now automatically set to the same folder where the image file was found. If your 'World Files' folder happens to be the same as the images folder, you just need to click on 'Ok' to the 'World files' folder dialog and proceed further.

5. GT_INSVX (GeoTools Polyline Tools Set1 Insert Vertex): A bug has been fixed in the GT_INSVX command. The Z value of the new vertex location is now the correctly interpolated Z value of the nearest point on polyline. Earlier, all new inserted vertices would acquire an elevation of 0.0. This has been fixed.

6. GT_IMPEX command enhanced: (GeoTools Export Tools Import/Export points and lines) : The GT_IMPEX command now has an additional option during import of points. You can specify a block attribute or object data field to receive the point elevation values. This is in addition to the transfer of 'Point Number' and 'Description' fields that be set as block attributes or object data fields.

7. GT_LAYERMAN command enhanced (GeoTools Miscellaneous Tools Layer Names Editor): The GT_LAYERMAN command now has an option to merge one layer into another. You can select multiple layers as source layers and specify one layer to merge all of them into.

8. GT_VIEWLINKED command (GeoTools Export Tools View handles-linked ASCII data) : The GT_VIEWLINKED command populates all records from the ASCII file into the dialog box. However, in BricsCAD, there is a bug which causes a huge performance loss when trying to populate large number of records into the popup list of the dialog box. To prevent this, the GT_VIEWLINKED command will list only the first 3000 records of the ASCII file in the dialog box in BricsCAD.

9. GT_PARTOFFSET command (GeoTools Polyline Toolset 1 Offset part of a polyline :  This command now handles 3d polylines fully and the offsetted segment also is a 3d polyline. Earlier, partial offsets from a 3d polyline would result in a 2d polyline.

10. GT_BATCHPROCESS command (GeoTools Miscellaneous Tools Batch process multiple drawings with scripts: The GT_BATCHPROCESS command can now do a recursive search starting from the selected folder and all folders below it and will create a BATch file to process all the files in one go. The earlier method of selecting one folder and drawings within the folder is still available.

11. GT_PROFILE (GeoTools -> Civil Tools Draw cross- sectional profiles): The GT_PROFILE command now accepts multiple 3d polylines for profiling. This will speed up profile generation when you want to generate mulitple cross-sections in one go.

12. GT_TRIANGULATE (GeoTools Civil Tools Create TIN (Delauney triangulation): The GT_TRIANGULATE command now allows you to specify the layer in which the TIN triangles are created.

13 GT_SET_Z_PL : GeoTools Drawing Cleanup 'Set all 0 elevation vertices to the nearest value' has been renamed as 'Set out-of-range elevation values to nearest valid elevation values'. The command name stays the same - GT_SET_Z_PL. In this new, enhanced mode, the command provides a dialog box interface and the option to specify an 'out-of-range' value. It need not be only 0.0 like before, any value can be specified as the 'out-of-range' limit and all values below it will be replaced with the nearest 'in-range' value. The change in the command description reflects this.

14. GT_SEGLABEL (GeoTools -> Annotation Tools ->Label polyline segments): The GT_SEGLABEL command now has a new option to do bearing annotations. It is the degree-minute-second format in the style DM'S". This has now been addded to complement the other available styles. Another addition is the 'Bearing@Distances' option.

15. GT_SET_Z_PL (GeoTools -> Drawing Cleanup -> 'Set out-of-range elevation values to nearest valid elevation values') : The GT_SET_Z_PL command has been modified and a new option has been added to delete the vertices of a 3d polyline which are 'out-of- range'. You now have the combined option to setting the 'out-of-range' elevations to their nearest valid value or simply delete that vertex.

16. GT_SEGLABEL (GeoTools -> Annotation Tools ->Label polyline segments): The GT_SEGLABEL command now has a new option to do bearing annotations. It is the degree-minute-second format in the style DM'S" and is preceeded by a N and succeeded by a E or W depending on whether you are in the 0-180 or 180-360 bearing zone.

17. GT_MERGEPOLY (GeoTools -> Polyline ToolSet1 -> Merge Adjacent polygons): The GT_MERGEPOLY command has been fixed and enhanced. It will now always create a 3d closed polyline representing the outline of the selected adjacent closed polylines. Whether the original polylines are 2d or 3d, the resulting enclosing polyline is always in 3D, even if it means creating one with all vertices set to 0.0. Additionally, inside gaps (islands) are now recognized and appropriate island polygons created. There is also an option now to create the merged polygon on a user-specified layer. The program uses some standard internal settings for fuzzy tolerance and search parameters. If you are using very small coordinates (like geographic) and notice strange results, let us know for help.

 

 

 

Interface changes

----

Bug Fixes
----

1. GT_QUERYPROC (GeoTools AutoCAD Map Tools Format text labels queried with 'Alter properties'): The GT_QUERYPROC command was not doing an offset of the queried labels by the specified amount in case of linear queried objects. This has now been fixed. Labels queried with 'Alter properties' Query in AutoCAD Map now can be fully controlled - justification, position, direction, XOffset, YOffset etc.

2. GT_INSVX (GeoTools -> Polyline ToolSet1 -> Insert Vertex) : This command now handles the dynamic placement of inserted vertex properly. Any OSNAPs that were in effect at the start of the command will now be restored at the end of the command.

3. GT_SPL2PL (GeoTools -> Conversion Tools -> Convert splines to polylines): The GT_SPL2PL command would fail in Windows Vista and Windows 7 if the User Account Control was On and the DXF method was invoked. This is because the command was attempting to create a temp file in the C:\ folder. This has now been fixed and the temp file creation is now done in the Windows TEMP folder where the permissions automatically exist.

4. GT_IMPORT2DM (GeoTools -> Miscellaneous Tools -> Import 2DM files as 3dface objects): The GT_IMPORT2DM command had a small bug which caused a spike (due to wrong coordinates reading) during the processing of points whose records number was 1. This has now been fixed.


 

GeoTools Tutorial

GeoTools Tutorial Lesson 14
This tutorial covers how to utilize some of GeoTools Block / Attribute tools to edit, modify the block attributes

 


Previous : Overview

Table of Contents

Next : Polyline Tools