Previous : Overview

Table of Contents

Next : Shortcut macros

 
What's New in GeoTools V5 - V12
GeoTools V5 GeoTools V6 GeoTools V7 GeoTools V8 GeoTools V9 GeoTools V10
GeoTools V12 GeoTools V13 GeoTools V14 GeoTools V15 GeoTools V16



What' new in GeoTools V11
( Includes all changes since the last update of GeoTools V10 [i.e. 10.15] )

GeoTools V11 is the first version of GeoTools to be compatible with AutoCAD 2011.

 

New commands added in GeoTools V11

GT_BC_OD2XD command: GeoTools -> AutoCAD Map Tools -> BricsCAD/plain AutoCAD compatibility tools -> Convert Object Table Data to Xdata) 

GT_BC_ODEDIT command: GeoTools -> AutoCAD Map Tools -> BricsCAD/plain AutoCAD compatibility tools -> Edit object data from AutoCAD Map

GT_BC_XD2OD command: GeoTools -> AutoCAD Map Tools -> BricsCAD / Plain AutoCAD compatibility tools -> Transfer Xdata to Object Data (for use after BricsCAD / Plain AutoCAD editing only

GT_DWGBROWSER command: GeoTools -> Miscellaneous Tools -> DWG Browser, with thumbnail preview

GT_HNDLABEL command: GeoTools -> Annotation -> Display object handles as text labels

GT_EXPLODE2LAYER command : GeoTools -> Blocks -> Explode blocks to a specified layer

GT_CREATEANNOT command : GeoTools -> Annotation -> Create annotations at intersections

GT_MEASUREMANY command : GeoTools -> Build -> Measure mulitple objects

GT_PLANARPOLY command : GeoTools -> Drawing Cleanup -> Make polylines/3dfaces planar

 

Commands Enhanced or changed

1. GT_PARTSTRETCH (GeoTools Polyline ToolSet 1 Stretch part of a polyline): A bug has been fixed in this command which caused malfunction of the command when the first segment of the polyline was picked for stretching.

2. GT_PARTROTATE (GeoTools Polyline ToolSet 1 Rotate part of a polyline): When the base point for rotation is asked, the OSNAP mode is now set automatically to ENDpoint. (enhancement)

3. GT_PARTOFFSET/GT_PARTCOPY/GT_PARTRESHAPE/GT_PARTROTATE/ GT_PARTSTRETCH (GeoTools Polyline ToolSet 1): All these commands now set and restore their OSNAP setting.

4. GT_XFER_OD_XD : (GeoTools AutoCAD Map Tools Transfer object data / xdata between two objects) : This command caused a crash in plain AutoCAD. This has been fixed.

5. GT_ALIGNTEXT (GeoTools Text Tools Align Text Objects) and GT_ALINGTEXT2LINE (Text Tools -> Align Text Objects to a line): These two commands now call and run correctly from the pull-down menu as well as the toolbars. Until now, they were calling a wrong command name and displaying a message to the effect that the command name has changed but with no offer to run that command.

6. GT_OD2XD (GeoTools AutoCAD Map Tools Convert object data to Xdata) : This command would not work correctly if there was only one object table in the drawing if the user clicked Ok without selecting it with a mouse click. The implicit, autmoatic selection of a single object data table was not working. This has been fixed now.

7. General change: All commands that require a block to be inserted would work correctly only if the block was defined with the default setting of "Non-Uniform scaling". If this default was changed and a block created with "Uniform XY Scaling", the block insertion would not work correctly in certain AutoCAD versions. This has now been fixed. A number of other small bugs have been fixed and improvements made.

8. General change: The AutoCAD menu bar with the GeoTools menu is now made visible automatically upon loading GeoTools.

Tip: In the event you do not see the AutoCAD (and GeoTools) menubar, type MENUBAR on the command line and set the value to 1.

9. GT_IMPEX (GeoTools   Export Import/Export points and lines) now provides an additional option under the 'Export Options' dialog box called 'Append object handle to the exported record'. If this option is checked, the last field in the exported record will be the object handle. When used in conjunction with the GT_HNDLABEL command, the handle export can be used as a means to correlate visually between the records in the ASCII file against the objects in the drawing.

10. The GT_MREDEFINE (GeoTools Block Tools Multiple Redefine Blocks-Lyr/Clr) command updates block definition - color, layer, elevation and thickness of objects. A new option 'LineWidth' has been added and this command will now update line widths of lines, polylines and arcs within the block definition.

11. The GT_IMPEX command (GeoTools Export Tools Import/Export points and lines) now supports additional options for import/export. You can specify 'Start' and 'Stop' codes for linear records. A Start or Stop code is added to each linear record at the beginning or end of the record and denotes if the point in question is the last point or not in a linear sequence of points.

12. The GT_AUTOINCROD command (GeoTools AutoCAD Map Tools Create auto-incrementing object table data) now has an additional option to assign incrementing object table data in a X/Y sorted manner. With options similar to those provided by the GT_SORTEDPOLY command, you can now assign incrementing object data with X/Y coordinates sorted.

13. The GT_ANNOGRID (GeoTools Civil Tools Create map grid): use supporting DWG files which used to be located in a common folder called 'BLOCKS' under the GeoTools installation folder. Anticipating that commands may need to use their own support files in the future, a new folder called "Support" has now been created under the GeoTools installation folder and all support files specific to each command will be placed in a folder by the name of that command.

For example, the support files used by GT_ANNOGRID will now be placed in <install_folder>/Support/ANNOGRID folder.

14. The GT_VEGLINE command (GeoTools Draw Tools Draw vegetation cover symbols) now offers 6 pre-defined PAR files which are useful to draw vegetation symbols for (T)rees, (S)hrubs and (H)edges, with scales of 1:200 and 1:500. The names of the files are HPOLY500.PAR, TPOLY500.PAR, SPOLY500.PAR, HPOLY200.PAR, TPOLY200.PAR and SPOLY200.PAR. You can use these files as a guide to set GT_VEGLINE parameters which are suggested best fits for the type of vegetation and the scales. If you don't like the parameters, feel free to save your own and retrieve later.

15. The GT_ATTEDIT command (GeoTools Block Tools Global Attribute Editor) now allows block attribute increments and decrements in real numbers also. Until now, only integer increments and decrements were possible

16. The GT_ENCLOSE command (GeoTools Text Tools Enclose Text in Box): The GT_ENCLOSE command now supports additional options to enclose text objects. You can now use either a WIPEPOUT, SOLID or 3DFACE object to create the enclosing bounding box. These are provided under the 'Box' sub-option and closely mimics the AutoCAD TEXTMASK command.

17. The GT_LAYERMAN command (Geotools Miscellaneous Tools Layer Names Editor): Two additional options have been introduced 'Add at Position' and 'Strip at Position'. These two options allow you to add or remove a specified number of characters from the layer name starting from a specified position.

For instance, if you have layers called LOTS-LABELS, LOTS-LINES and LOTS-CENTROIDS and would like to rename them to LOTS-OLD-LABELS, LOTS-OLD-LINES and LOTS-OLD-CENTROIDS, this is the tool to use.

18. The GT_SURFAREA command (GeoTools Miscellaneous Tools Compute surface area of 3dFACEs): can now be used to optionally create 'projected' 3DFACE objects on the XY plane, when you choose the option 'Projected(horizontal)' area. This is in addition to the projected area reporting that is performed by the command.

19. The GT_INSVX command (GeoTools Polyline ToolSet 1 Insert vertex) : Until now,you were only able to add a new vertex at a point on the existing segment of the polyline. The GT_INSVX now allows you to pick a point outside the polyline and a new vertex will be added at the picked location. The segment closest to the picked point will redraw itself to include the new vertex.

20. The GT_FLIP command (GeoTools Polyline ToolSet 1 Flip(reverse) direction of polylines): The GT_FLIP command has been made more intuitive, with clearer dialog descriptions. A bug has been fixed which affected 2- vertex polylines. Additionally, support for LINE objects has been added when 'High-2-Low' and 'Low-2-high' options are chosen.

21. The GT_ENDELEVCHECK command (GeoTools Drawing Cleanup Tools Check for coincident (XY) endpoints with varying Z):The GT_ENDELEVCHECK command now provides an option to create a single 3d polyline from the joined objects.

22. The GT_3DJ command (GeoTools Polyline ToolSet 1 Join 3D Polyines) : The GT_3DJ command now allows LWPOLYLINE objects to be selected as inputs. You can now provide a combination of light-weight, heavy-weight polylines as well as lines and 3DPOLYlines as inputs for this command.

 

 

Interface changes

----

Bug Fixes
----

1. GeoTools V11 (running in trial mode only, not licensed versions) was causing an unexplained freeze in AutoCAD 2011 and the only way out was to shut down AutoCAD. This has now been fixed. We apologize for the inconvenience this has caused to all our AutoCAD 2011 evaluation users.

2. Some commands in GeoTools were incorrectly displaying a message "There is no license to run this command". This bug sneaked in during one of the earlier updates back and has been fixed now.

3.The GT_DRAPEPOLY (GeoTools Build Tools Drape a 3d polyline across a set of intersecting linear objects) command would freeze AutoCAD if a LINE object was supplied as a source object. This has been fixed now.


 

GeoTools Tutorial

GeoTools Tutorial Lesson 14
This tutorial covers how to utilize some of GeoTools Block / Attribute tools to edit, modify the block attributes

 


Previous : Overview

Table of Contents

Next : Shortcut macros