GeoTools Logo

Lesson 2

Prev : Lesson 1

Table of Contents

Next : Lesson 3


This tutorial covers some of the GeoTools commands for working with 3D Polylines to create a road layout along with footpath and Civil tools for annotating chainage.

1. Open the drawing named lesson2.dwg which is located in your GeoTools Tutorials folder. This folder is located in the folder where you have installed GeoTools.

2. You should see a drawing (see Image 4-8) of a small layout of road median under development represented by 3D Polyline.

Image 4-8

3. First we will join the two median 3D-polylines, 

Joining 3D Polylines

1. Click on the menu GeoTools =>Polyline Tools=> Join => Join 3D Polylines or type GT_3DJ at the command prompt.
Note: The segments to be joined must be exactly touching each other.

Image 4-9


2. Then you are prompted to select the 3D polylines to join. You can select in two ways i.e. 

a) Select the 3D polylines to join manually or 

b) Press Enter key to select the layers for joining the 3D polylines. Image 4-10 shows the dialog box you get for selecting the layers for joining 3D polylines.

Image 4-10
    
 

 

After performing the above steps the 3D-polylines touching each other are joined, so our next process will be to offset the 3D-polyline for creating pavement edge on either side.



Offsetting the 3D-polyline.

1. Click on the menu, GeoTools => Build => Offset 3D polylines. or type GT_3DOFFSET at the command prompt.



2. Select the 3D polyline and specify the offset distance 10 feet both horizontally and vertically 

3. Offset the 3D polyline on either sides. This two 3D polylines represent the pavement edge on either sides of median.

4. While offsetting a message box will be displayed as shown below in (Image 4-12) stating the number of vertices of source and offsetted polyline

Image 4-12

5. The result will be two 3D polylines offsetted on either sides representing Pavement edges.

6. Create a new layer by name Pavement, and make it as current layer.

7. Now we will transfer this two 3D polylines into the newly created layer Pavement

8. For doing so select the 3D Polylines representing Pavement Click on Modify menu => Properties => Layer => select Pavement layer

Now our next step will be to create Footpath on either sides of the Pavement. For doing so repeat steps 1 and 2 from Offseting the 3D Polylines but keep the offset distance 5 Feet.

9. The result will be two 3D polylines offsetted on either sides for 10 feet representing Footpath 

10. Create a new layer by clicking on menu. Format => Layer- > New name the new layer as Footpath, and make it as current layer.

11
. Now our next step is to transfer the 3D polylines representing Footpath into the layer Footpath.  

12. For doing so select the 3D Polylines representing FootPath Click on Modify menu => Properties => Layer => select FoothPath layer    

13. Apply different colors to Pavement and Footpath layer for differentiating them easily. Similar to the one shown below in (Image 4-13)

Image 4-13


 

After learning how to join and offset 3D polylines now we will see how to annotate chainage distances along this road segment. 

 

Annotate chainage distances along road segment

1. Click on the menu, GeoTools => Civil Tools => Annotate chainages along a route. or type GT_Chainage at the command prompt, 

2. You will be prompted to select the polyline to annotate, select the Median 3D polyline (Green color) to annotate, after selecting the polyline a dialog box will pop-up as shown below in (Image 4-14)

Image 4-14

3. Enter the values in the boxes and tick mark the buttons as shown in the above (Image 4-14).

4. Click on OK button for generating the chainage annotation for the 3D polyline representing the Median as shown below in (Image 4-15).


Image 4-15


After learning how to annotate chainage distances along road segment. Now we will see how to get the detailed road segment information (Polyline statistics)

 

Detailed polyline statistics

1. Click on the menu, GeoTools => Polyline Tools => Inquiry and Statistics => Compute detailed polyline statistics. or type GT_PL_STAT at the command prompt, this  will  pop-up the dialog box as shown below in (Image 4-16)


Image 4-16

2. Check the box Create statistics output file this will save the output to an ASCII text file. And click on Browse button to specify the path for saving the polyline statistics output file.

3. Check the box Create tabular output this will generate the polyline statistics in table format as a text object, specify the required Table Text Height. And then click on OK button the dialog box will be unloaded and you will be prompted to select the polyline, select the 3D polyline of which you want to generate detail statistics.

4. This generates statistics like Slope length, Max X, Y coordinates etc. and will be displayed on AutoCAD / BricsCAD text window you will be prompted to press any key  to continue. 

5. Once all the details are displayed you will be prompted to pick start point of table for generating the same details on AutoCAD drawing area 

6. Pick a point in a blank area and you will see detailed polyline statistics been generated. And the same details are also stored in the form of text file in the path you specified.

An example of polyline statistics is listed below.

 

Vertex #           X-Coord           Y-Coord           Z-Coord            SegmentLength             SegmentSlope(%)            SegmentSlope(degs)    Azimuth(Bearing)

1                      286157.11       1972058.58     485.67                         0.70                     +13.57%                      7.73 degs                        Up 200.57

2                      286156.86       1972057.92    485.76                         9.41                      +15.83%                      8.99 degs                         Up 203.44

3                      286153.17       1972049.39    487.23                         9.40                      +14.83%                      8.43 degs                         Up 206.30

4                      286149.04       1972041.06    488.61                         9.38                      +13.04%                      7.43 degs                         Up 209.17

5                     286144.51       1972032.94    489.82                         9.53                       +12.20%                      6.95 degs                         Up 212.03

6                      286139.49       1972024.92    490.98                         9.73                      +11.93%                      6.80 degs                         Up 214.28

7                      286134.05       1972016.93    492.13                         9.72                      +11.71%                      6.68 degs                         Up 215.68

8                      286128.42       1972009.09    493.26                         9.71                      +9.76%                        5.57 degs                         Up 217.04

9                      286122.60       1972001.37    494.20                         9.71                      +9.53%                        5.44 degs                         Up 218.40

10                    286116.59       1971993.80    495.12                         9.71                      +8.83%                        5.04 degs                         Up 219.76

 

 

Prev : Lesson 1

Table of Contents

Next : Lesson 3