Previous : Overview

Table of Contents

Next : Shortcut macros



What' new in CADPower V16
( Includes all changes since the last update of CADPower V15 [i.e. 15.22] )

CADPower V16 is compatible with AutoCAD versions 2007-2016 and BricsCAD V15, V14 and V13.

 

New commands added in CADPower V16

CP_MOVEBAK -or- MOVEBAK: BricsCAD lacks the MOVEBAK command of AutoCAD. This is now available in BricsCAD via CADPower. The CP_MOVEBAK command allows the .bak folder to be specified via a dialog box, while the MOVEBAK command does the actual moving of .BAK files to the designated folder. This command is available in the BricsCAD version only.

CP_TEXTMASK -or- TEXTMASK: (CADPower-> Text-> Display -> TEXTMASK): The new TEXTMASK command in BricsCAD emulates the TEXTMASK command in AutoCAD. The TEXTMASK command uses WIPEOUT objects underneath to mask the text. These are created with frames set to OFF. The only slight difference between the AutoCAD implementation and the BricsCAD implementation is that, in BricsCAD, the WIPEOUT does not automatically move or update with the text if text is updated. This command is available in the BricsCAD version only.

CP_TXT2MTXT -or- TXT2MTXT: (CADPower-> Text-> Editing-> Consolidate Text into MText (quick version)): The TXT2MTXT command (also runs as CP_CONS_QMTXT command) is a quicker version of the existing CP_CONS_TXT command that more closely emulates the AutoCAD command by the same name. This command is available in the BricsCAD version only.

CP_HOLETABLE
: (CADPower -> Draw -> Rule-Based -> Hole table):
It is now possible to create a hole-table in CADPower and export the same into Excel via CSV files.

Hole tables are a useful means of defining the size and location of a hole. A hole table works much like a software spreadsheet. Holes are represented as rows in the table and dimensions and other properties of the holes as columns. Circles, points, blocks (with or without attributes) can be represented in a hole-table.

A hole-table is a list of coordinates of a 'hole' in a sheet metal that serves as a guide for punching operations. Typical properties that can be captured in the hole-table are X & Y coordinates, diameter (for circular holes), block names and optionally attribute values.

CP_POLYAREACREATE
: (CADPower -> Draw -> Rule-Based -> Draw closed polylines to an exact area):
The CP_POLYAREACRATE command creates a closed polyline (polygon) of an exact area. For example, if you have drawn the shape of your polygon but want to scale it up or down such that it measures to an exact area, you can use this command.

CP_CSVEXPORT
: (CADPower -> Export -> Export CSV file):
This is a quick tool to export columns of text data into CSV file. 

CP_BLKMAN: (CADPower -> Blocks -> Block Names Editor): The CP_BLKMAN command functions in a very similar manner to the CP_LAYERMAN command. It allows multiple blocks to be renamed in flexible ways using wildcards and patterns.

CP_DWGAUDIT: (CADPower -> Miscellaneous -> CAD Procedures -> Perform drawing audit and cleanup): The CP_DWGAUDIT command is a utility to clean up a drawing of unwanted symbol table information, temporary blocks and also offers a method to flatten the Z values of entities within blocks.

CP_VPEXTRACT: (CADPower -> Viewports -> Extract clipping boundary): The CP_VPEXTRACT command is used to extract the clipping boundary of a viewport as a closed polyline or circle.The extracted entity can be edited and used as an updated boundary for the next command, CP_VPBNDRYUPDATE.

CP_VPBNDRYUPDATE: (CADPower -> Viewports -> Update clipping boundary): The CP_VPBNDRYUPDATE command is used to update the clipping boundary of a viewport and replace it with a new one.

CP_BUILDWLALLS: (CADPower -> BOM/BOQ Tools -> Draw Developed Walls from plan footprint): The CP_BUILDWALLS command is used to draw a developed elevation view of a set of connected walls from its plan footprint

CP_SEGLENHGTSET: (CADPower -> BOM/BOQ Tools -> Set Height & Length of wall segments): The CP_SEGLENHGTSET command is used to set the heights of individual walls in a room. The room footprint is represented by a closed polyline and each wall is a segment of the polyline.

CP_PLACEFIXTURES: (Menu: CADPower -> BOM/BOQ Tools -> Place Openings): CADPower defines two blocks for openings: SP_OPENINGS_ELEV and SP_OPENINGS_PLAN. This is a simple rectangular block that has the following attributes: SILL_HEIGHT, WIDTH, HEIGHT, DEPTH (for recesses) & TYPE.

CP_COMPUTEWALLAREAS: (Menu: CADPower -> BOM/BOQ Tools -> Compute Wall/Openings areas): The CP_COMPUTEWALLAREAS command takes wall elevations and the window/door/openings and computes a schedule of fixtures, their areas as well as the net area of walls.

CP_DATAMAN (CADPower -> Build -> Data Manager): The CP_DATAMAN command is used to define a simple XDATA based database which operates entirely inside your CAD drawing. All data is stored in XDATA attached to entities and the database definition is provided in a simple INI file.

CP_LINEQTY (CADPower -> BOM/BOQ Tools -> Compute linear quantities): The CP_LINEQTY command creates a quantity summary using physical length, wieght/unit lengh and cost/unit length as the primary parameters.

CP_INIEDITOR (CADPower -> Miscellaneous -> File Management-> INI Editor): The CP_INIEDITOR command 
is used to edit INI files used by various CADPower commands.

CP_PATTERNPLACER: (CADPower -> Draw -> Symbology -> Pattern Placer): The CP_PATTERNPLACER command is 
used to arrange a pattern inside a polygonal boundary in a row-wise manner.

CP_ENVSET command is used to offer a clean user-interface in BricsCAD when moving from one workspace to another.

CP_WIPEOUT (CADPower -> Miscellaneous -> CAD Procedures -> Second Set -> Wipeout buffer around a polygon): The CP_WIPEOUT command is useful to create a WIPEOUT mask around a closed polygon by defining a buffer (offset) zone around the polygon.

 

 

Commands Enhanced or changed

CP_DEBUGINFO: (command line only): Additional reporting in BricsCAD now lists the mulitple locations on the search path in which the on_doc_load.lsp and CADPower license files were found. This is useful in debugging and configuration.

CP_CGRID
: (CADPower -> Draw -> Geometry -> Construction Grid):
The CP_CGRID command has improved data input. You can now enter the angle between the two grid lines in 'Interactive' circular mode. Entering a value like '20A' creates the grid line at an angle of 20 degrees from the last line.


CP_PERP
: (CADPower -> Draw -> Geometry -> Perpendicular Lines):
The CP_PERP command now allows to draw a perpendicular line from a circle object also.

CP_PL_STAT
: (CADPower-> Polyline Tools -> Inquiry Statistics -> Compute detailed polyline statistics):
The 'Z-Coords' column name in the CSV file was repeated twice. This has been corrected and the column is now correctly labeled as 'Segment Length'.

CP_FIXCLOSED: (CADPower -> Polyline Tools -> Vertex Management-> Add/Remove redundant closing vertex in polyline): Reporting improved. Better messaging of the actions of the program now ensures that the user is clear about how many polylines were processed, and whether the redundant vertices were added or removed.

CP_CREATECENTROID: (CADPower -> Build -> Create centroid marks inside closed polygons): The CP_CREATECENTROID command now supports SPLINEs also in addition to polylines and circles.

CP_IDXYZ: (CADPower -> Annotation -> Label points): Small red temporary square marker is now added for all point annotations picked on a blank area. This provides a visual cue about the point picked.

CP_CGRID: (CADPower -> Draw -> Geometry -> Construction Grid)

  • The grid lines, labels and the balloon circle now can be created in their own layers instead of everything being on the current layer.

  • The CP_CGRID command dialog box resized and the height has been reduced. This enables the dialog to display correctly under all display resolutions.

CP_TC: (CADPower-> Text-> Creation-> Draw Quick Text (running numbers): The CP_TC command dialog box resized and the height has been reduced. This enables the dialog to display correctly under all display resolutions.

CP_INSVX:(CADPower-> Polyline-> Vertex Management-> Insert Vertex) A red color temporary marker is displayed where the vertex was created.

CP_ROUGHEN: (CADPower -> Draw -> Symbology -> Roughen a line): 

  • The CP_ROUGHEN was crashing in BricsCAD Classic. This has been fixed 

  • The command was generating a closed roughened polyline even if the original object was open. This also has been fixed

CP_MODTXT : (CADPower -> Text -> Editing -> Globally modify TEXT/MTEXT): the 'Set Value' or 'Trim characters' option of this command results in an empty string, the text in question now gets deleted and does not result in a null-text entity. This results in a cleaner drawing with no phantom text objects.

CP_PL_STAT: (CADPower -> Polyline Tools -> Inquiry Statistics -> Compute detailed polyline statistics): The name of the default output file has been changed from PL_STAT.txt to <drawing_name>_PL_STAT.csv to relate the output with the drawing and import into Excel easily.

CP_SCALE_Z: (CADPower -> Conversion -> Scale Z values): This command now accepts 3dface objects also for Z scaling.

CP_CMDHELP (CADPower -> More Options -> Specific Command Help): GeoTools & CADPower are companion products that work in concert. If you enter the name of a command in one product and if it does not exist, it is searched for in the other product and displayed if it exists there. This ensures that the user can locate the command in either software and get help from one single place

The CADPower -> Miscellaneous -> CAD Procedures menu item has been split into two lists for better readability. The CAD Procedures section is now split as 'First Set' and 'Second Set'

CP_TILEPLACE (Menu: CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): The CP_TILEPLACE command now automatically detects and processes island polygons within the main one and the panels are placed accordingly.

CP_BOM: (CADPower -> BOM/BOQ Tools -> Create Bill of Materials/Quantities) has been enhanced.

  • A CSV output of computed quantities & cost listing is now automatically generated for ALL the BOM types, including the 'Count Attribute Value' method, which was excluded until now.

  • The 'Random', 'Aligned' and 'Offset' placement type prompt which appears as the last prompt during CP_BOM has been removed. Nearly all users always only use the 'Aligned' option and this is now the default. The 'Offset' parameter is set within the dialog box. The 'Random' option is not relevant and has been removed.

CP_IDXYZ: (CADPower -> Annotation -> Label points)

  • Choosing 'Coordinate Annotation' as the annotation format caused the Prefix/Suffix options to be grayed out. This has been fixed.

  • The offset distances for 'Coordinate Annotation' is now defaulted as 1.25 times the text height. This gives a properly spaced annotation in Easting and Northing. Earlier the user had to make sure to set a proper spacing, failing which the annotations would overlap and look ugly.

CP_DELSVP: (CADPower -> Polyline Tools -> Vertex Management -> Delete single vertex polylines): The command was throwing a typo on command line. Fixed now.

 


Previous : Overview

Table of Contents

Next : Shortcut macros