Previous : Overview

Table of Contents

Next : Shortcut macros



What' new in CADPower V15
( Includes all changes since the last update of CADPower V14 [i.e. 14.33] )

CADPower V15 is compatible with AutoCAD versions 2007-2015 and BricsCAD V15, V14 and V13.

 

New commands added in CADPower V15

CP_BOM: CADPower -> BOM / BOQ Tools -> BOM Generator

CP_DIVPOLY: CADPower -> Miscellaneous -> CAD Procedures -> Divide a 3/4 sided polygon

CP_TXTSPACING: CADPower -> Text -> Display -> Adjust spacing of text objects

CP_TXTCHANGE: CADPower -> Text -> Display -> Exchange one text with another

CP_CHCASEQUICK: CADPower -> Text -> Conversion -> Quick Change Case

CP_GRIPHATCH (command-line only): Grip-edit Hatches in BricsCAD

CP_XD_RENAMEAPP: CADPower -> Extended Entity Data -> Rename XDATA application name attached to entities

CP_LINEPLANEINT: CADPower -> Miscellaneous -> CAD Procedures -> Determine the intersection of line and plane

CP_DIMTXTEXTRACT: BricsCAD+ -> Extract text from dimension

CP_XD_RENAMEAPP: CADPower -> Extended Entity Data -> Rename XData application name attached to entities

CP_TILEPLACE: CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels

CP_TILECOUNT: CADPower -> BOM/BOQ Tools -> BOM: Count tiles / XY panels

CP_TILEOFFSET: CADPower -> BOM/BOQ Tools -> Offset tiles / XY sized panels

CP_BO: CADPower -> Blocks -> Block-related -> Select and export Block to DWG

CP_BI: CADPower -> Blocks -> Block-related -> Select and import Block from DWG

CP_BLKSLIDE: CADPower -> Blocks -> Block-related -> Slide (move) block relative to its rotation angle

CP_CMDHELP: CADPower -> More Options -> Specific command help

CP_LASTCMDHELP: CADPower -> More Options -> Display help for last command

CP_CGRID: CADPower -> Draw -> Geometry -> Construction Grid

CP_JOINCOLLINEAR: CADPower -> Miscellaneous -> CAD Procedures -> Join collinear lines & polylines

CP_SHAPEMANAGER: CADPower -> Miscellaneous -> CAD Procedures -> Shapes Manager

CP_ELLIPSE2CL: CADPower -> Conversion -> More Conversion-> Ellipse 2 Circles

CP_LINE2XLINE: CADPower -> Conversion-> Lines/Polyline/Arc/Splines-> Line 2 XLINE

CP_LINEEQ: CADPower -> Draw -> Geometry -> Equation of a Line

CP_RECTLB: CADPower -> Draw -> Geometry -> Rectangle with dimensions

CP_MARLEVELS: CADPower -> Annotation -> Mark levels above-or-below a selected datum

CP_UNITCONV: CADPower -> Conversion-> Units change

CP_FIXUCS: CADPower-> Polyline Tools -> Others -> Fix lines/polylines with different UCS

 

 

 

Commands Enhanced or changed

CP_TC (CADPower-> Text-> Creation-> Draw Quick Text (running numbers)): A new option to automatically apply incrementing text on pre-existing text has been added. The incrementing can be done as per X or Y direction sorting.

CP_AUTODIM: (CADPower -> Miscellaneous -> CAD Procedures -> Automatic Dimensioning): The CP_AUTODIM command now accepts lines, polylines, arcs, circles as well as splines as input and an automatic dimension is now created cutting across all these entities.

CP_TC: (CADPower-> Text-> Creation-> Draw Quick Text [running numbers]): Alpha-numeric incrementing of text is now possible. If you set the starting charater value as A8, the series is now incremented as A9, A10, A11..... and so on.

CP_PL_STAT: (CADPower -> Polyline Tools -> Inquiry Statistics -> Compute detailed polyline statistics): A new option has been added which allows the polyline statistics export file to be specified with a delimiter. This allows easy import and processing of data in Micrisoft Excel.

CP_VISIT: (CADPower -> Inquiry -> Object selection browser): The CP_VISIT command has been enhanced and now supports dimension as well as spline objects also.

CP_XD_SEARCH (CADPower -> Extended Entity Data -> Search and replace extended entity data): A new option called 'Search all codes' has been added in this command. Using this option, you can replace multiple (all) occurrences of the selected XDATA code in one single operation instead of having to repeat the operation one at a time.

CP_BOM (CADPower -> BOM/BOQ Tools -> Create Bill of Materials/Quantities): The CP_BOM command now optionally also processes external reference blocks.

CP_TXTEVAL (CADPower -> Text -> Apply arithmetic/statistical operations on text objects): A new option called 'Sum [Add up]' has been added which will add up all the selected numbers and create a new text (or block) object.

CP_BOM (CADPower -> BOM/BOQ Tools -> Create Bill of Materials/Quantities): It is now possible to import any CSV file directly using CP_BOM command not just the ones exported by CP_BOM. Earlier this was limited only to 'Attribute Extraction' workflows. Two new BOM types have been introduced called as 'COUNT ATTRIBUTE VALUES' and 'INDEXEDBOM'

CP_TC: (CADPower-> Text-> Creation-> Draw Quick Text [running numbers]): A new option called 'Scale Factor' has been added. you can now specify the scale factor of blocks as they are inserted which offers a better control over placing of blocks.

CP_TC: (CADPower-> Text-> Creation-> Draw Quick Text [running numbers]): A bug which was causing an error in updating the text sequence when a new item was inserted or deleted has been fixed.

CP_MODTXT: (CADPower-> Text -> Editing -> Globally modify Text/Mtext): The CP_MODTXT command now has an option to set selected text objects upright. Setting a text object upright involves rotating the text by 180 degrees if its rotation angle is between 90 and 270 degrees. This is a new global text editing option no available under the CP_MODTXT command.

CP_IDXYZ: (CADPower -> Annotation -> Label points): Quiet a few new enhancements have been made in CP_IDXYZ command

  • A new option has been added to set the precision from within the command itself. It is no longer depended on the precision in the General Settings (CP_GENSET)

  • An option has been added to suppress trailing zeros.

  • An option has been added to specify a suffix after each co-ordinate. The suffix can be added once at the end of the annotation string or after each co-ordinate value.

CP_TXTROUND (CADPower -> Text -> Editing -> Round off numeric text: An option has been added to suppress trailing zero's 

CP_TOOLHIDE (CADPower -> Settings -> Perform Show/Hide toolbars in all workspaces

CP_TOOLSHOW (CADPower -> Settings -> Perform Show/Hide toolbars in all workspaces

CP_GENSET: (CADPower -> Settings): A new general setting called 'Do Not Show User-Interface' has been added. Checking this option causes CADPower to load without any menus or toolbars

CP_CGRID: (CADPower -> Draw -> Geometry -> Construction Grid): The CP_CGRID command has been enhanced. It can now draw a circular grids also, either automatically to fill a circular area or interactively at picked point locations. The other option provided by this command is to create automatic or manual rectangular grid lines.

CP_TILEPLACE: (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): The CP_TILEPLACE command has been significantly enhanced. You now have options to specify the gap between the tiles along the direction of placement as well as across two rows of tiles. You can also specify exactly the offset distance between tile joints in adjacent rows. This enables designers to place tiles with aesthetically pleasing pattern as required and enables the CP_TILECOUNT command to count the tiles effectively.

CP_TILEPLACE (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): It is now possible to run this command even without assigining or saving an INI file

CP_LENTEXT: (CADPower -> Annotation -> Create/update length annotation): The CP_LENTEXt command has been enhanced. It is now possible to simply pick two points on the drawing and create a distance annotation between them. The earlier method of picking existing entities also is available. The two point pick is enabled by pressing ENTER when asked to select an entitiy to do distance annotation. Additionally, CP_LENTEXT now offers a number of pre-set distance converters based on commonly used units like mm, cm, in, ft and yards.

CP_TILEPLACE (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): It is now possible to use attributes in blocks which server ads image maps.

CP_XP_ATT (CADPower -> Blocks -> Block-related -> Explode Block- Retain attributes as Text): The CP_XP_ATT command has been improved. The attributes which are recreated as text objects are now placed in front (using DRAWORDER) after the command has run. This gives better visual look (especially when using raster images for tiles) after the program has run and is most likely what people want to see as the desired output.

CP_TILEPLACE (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): The CP_TILEPLACE command has been improved. The boundary polyline is now placed in front (using DRAWORDER) after the command has run. This gives better visual look (especially when using raster images for tiles) after the program has run and is most likely what people want to see as the desired output.

CP_CGRID: (CADPower -> Draw -> Geometry -> Construction Grid): Major improvements have been made in this command. It is now possible to create interactive rectangular and circular grids using manual distance inputs which specify the distance between the grid lines.

CP_GENSET: (CADPower -> Settings): The CP_GENSET command has been enhanced. Two new options have been added which will be implemented gradually through the software. The first one is called 'Beep on Error'. This setting allows a beep sound to be generated each time CADPower encounters an error. The default is 'No Beep' and the function remains dsiabled unless you explicitly set it on and select a beep sound from one of six different beep tones.

The second new option is 'Enable voice mode for important messages/errors'. Checking this option activates Windows speech tools to speak out the important prompts, messages or error notifications. This tool may be useful for those experiencing difficulties in readimg prompts on the command line or for those using the latest version of AutoCAD which makes it very difficult to read command-line prompts anyway.

CP_GENSET: (CADPower -> Settings): CADPower defines a number of keyboard shortcuts which were disabled by default and were enabled using the CP_DDEFMACROS command only. This is inconvenient for users to remember and manage. but from now onwards, a new option is provided in the Settings dialog to control this. You can enable or disable macros by clicking on 'Enable CADPower macros upon start'.


CP_CMDDLG (not available in menus) is a maintenance command that is useful to switch the command line mode of CADPower 'On' or 'Off'. This command was not functioning correctly in the past few updates because of a mis-matched command keyword stack map. This has now been fixed.

 

 

 

Interface changes

----

Bug Fixes
----

CP_ALIGNTEXT (CADPower Text Display Align Text objects): command was not showing the MTEXT option. This has been fixed

CP_CALCAREA (CADPower-> Polyline-> Inquiry Statistics-> Compute summed areas of closed polylines): There was a bug in this command when reporting area units in sq.m if the drawing unit was in mm. The output figure was off by a decimal place and was appearing 10 times larger than required. This has been fixed now

Toolbar default display: Upon starting CADPower for the first time, the toolbars are NOT automatically displayed now. You can show and hide individual toolbars using the 'CADPower -> Toolbars & Flyouts' menu.

Duplicate loading of pull-down menus: This has been fixed.

CP_FLIP (CADPower -> Polyline Tools -> Flip -> Flip (Reverse) direction): There was a bug which caused wrong results if a closed 2d polyline had a non-zero elevation. This has been fixed now.

CP_MVEDIT: (CADPower-> Polyline-> Vertex Management-> Mulitple Vertex Editor): The graying-in and out of the edit tiles have been made and is in sync now.

CP_BOM: (CADPower -> BOM/BOQ Tools -> Create Bill of Materials/Quantities): There was an inconsistency in the way the 'MultipleBlocks' based BOM blocks selection was processed. The blocks defined in the INI file are now considered as the blocks which will be selectable for processing.

CP_ATTUPRIGHT: (CADPower -> Blocks -> Attribute-Related -> Make attribute readable): The attributes now set themselves upright for all types of text justifications. The process of setting an attribute text upright involves flipping the text by 180 degrees when it is not readable with the head upright.

CP_TC (CADPower Text Creation Draw Quick Text (running numbers)): A bug which was causing an error in updating the text sequence when a new item was inserted or deleted has been fixed.

CP_TILEPLACE (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): A number of checks and fixes have been applied to the code which was causing some crashes in using CADPower for AutoCAD.

CP_CGRID: CADPower -> Draw -> Geometry -> Construction Grid): The incrementing values of the grid numbers for the horizontal, vertical and circular grids was incorrect and has been fixed.

CP_TILEPLACE (CADPower -> BOM/BOQ Tools -> Place tiles / XY sized panels): The 'Populate attributes' option to specify the SIZE and DESCRIPTION attribute had a bug and was crashing when the 'Fill Poly' option was exercised. This has been fixed now.

CP_OFFSET (CADPower -> Build -> Offset -> Offset and delete original): This command was broken and has been fixed.

CP_INOUTOFFSET (CADPower -> Polyline Tools -> Others -> Offset closed polylines Inwards/Outwards): This command was broken and has been fixed.

CP_MODTXT: (CADPower -> Text -> Editing -> Globally modify TEXT/MTEXT): The 'Make Text Upright' option in this command failed on certain types of text justifications. This has been fixed now. Other minor improvements to the interface has been made to make the program behavior more predictable and consistent.

CP_ATTEXT (CADPower -> Blocks -> Attribute-related -> Extract Block attributes to file): This command was broken and has been fixed.

CP_MVOFFSET (CADPower -> Build -> Offset -> Mulitple Variable Polyline segment offset): This command was broken and has been fixed.

CADPower for BricsCAD Classic has some fixes in place. The program will no longer cause a startup freeze in BricsCAD V15 when trying to load Express Tools and LoftX.dll. An auto-dectect mechanism has been put in place.

 

CADPower Tutorial

Lesson 1 - Polyline and Annotation Tools
In this lesson we cover how to utilize polyline tools for converting the polyline from 2D to 3D and assigning 'Z ' values to it.

Lesson 2 - Polyline Editing and Build Tools
In this lesson we cover how to edit 3D polylines and get details using Build Tools.

Lesson 3 - Block and Conversion Tools
In this lesson we cover how to utilize some of the block tools for representing Lots and marking there centroid.

Lesson 4 - Text Tools
In this lesson we cover how to utilize some of the text tools for editing and modifying the text in the drawing.

Lesson 5 - Inquiry Tools
In this lesson we cover how to utilize some of the Inquiry tools for finding out the details of the Lots.

Lesson 6 - Annotation Tools
In this lesson we cover how to utilize some of the Annotation tools for Annotating the polylines.

Lesson 7 - Conversion Tools
In this lesson we cover how to utilize some of the frequently required conversion tools in road development. 

Lesson 8 - Polyline, Block and Text Tools
In this lesson we cover how to utilize some of the Polyline, Block and text tools for working with block attributes.

Lesson 9 - Block Tools for Exporting and Editing Attributes
This tutorial covers how to utilize some of Block tools for Exporting (extracting) and editing block attributes.

Lesson 10 - Block / Attributes Editing and Modifying Tools
This tutorial covers how to utilize some of CADPower Block / Attribute tools to edit, modify the block attributes.

Lesson 11 - Text Tools
This tutorial covers how to utilize some of CADPower Text tools to change case of text, consolidate Text into Mtext and print Date / Stamp

 


Previous : Overview

Table of Contents

Next : Shortcut macros