Previous : Overview

Table of Contents

Next : Shortcut macros



What' new in CADPower V14
( Includes all changes since the last update of CADPower V13 [i.e. 13.12] )

CADPower V14 is compatible with AutoCAD versions 2007-2014 and BricsCAD V14 and V13.

 

New commands added in CADPower V14

CP_READEXIF: CADPower Miscellaneous -> File Management -> View / Extract EXIF data 

CP_SEGDEL: CADPower Polyline Tools  -> More Editing -> Delete Segments from Polyline

CP_CHECKUPDATES: CADPower More Options  -> Check for updates

CP_DEBUGINFO: CADPower More Options  -> Debug Information

CP_DIMPREC: CADPower Miscellaneous -> CAD procedure -> Change Dimension Precision

CADPower Tutorial: -> The CADPower tutorial has a total of 11 lessons to help you to use CADPower commands effectively in your work and understand its full potential.

CP_REPURL: -> CADPower Miscellaneous -> CAD procedure -> Search / Replace attached URL

CP_TWEAKPOLY: -> CADPower Polyline Tools  -> Vertex Management -> Tweak polyline vertex

CP_CMDSEARCH: CADPower -> More Options -> Search GeoTools / CADPower commands

CP_CMDLIST: CADPower -> More Options -> List GeoTools/CADPower commands

CP_IMAGEPOLYCLIP: -> CADPower Miscellaneous -> CAD procedure -> Clip an image along a boundary polygon

CP_IMAGETRIM: -> CADPower Miscellaneous -> CAD procedure -> Trim an image along a boundary line

CP_FINDHND: -> CADPower Inquiry -> Search entities via handles

CP_LINEEQ (CADPower Draw Geometry Equation of a Line)

CP_LINE2XLINE (CADPower -> Conversion-> Lines/Polyline/Arc/Splines-> Line 2 XLINE)

 

 

 

Commands Enhanced or changed

CP_CONS_TXT (CADPower -> Text -> Editing -> Consolidate Text into Mtext): The CP_CONS_TXT command now gives you an option to delete the original text objects after consolidatng the same into a MTEXT object.

CP_CONS_TXT (CADPower -> Text -> Editing -> Consolidate text into MText/Text): The CP_CONS_TXT command has been updated. It now accepts text also, in addition to MTEXT. You can now combine many text objects into one single MTEXT object or into one concatenated text object.

CP_MATCH (CADPower Miscellaneous CAD Procedures Match object properties): The CP_MATCH command has been completely re-designed. It now accepts text also, in addition to MTEXT. You can now combine many text objects into one single MTEXT object or into one concatenated text object.

CP_GENSET: CADPower->Settings -> Force reload of CUI at startup

Minor enhancement: Many CADPower commands offer dialog boxes within them that allows selection from a list of available choices. When the choices are many, selecting exactly what you need can be cumbersone. A new 'Filter' option has been added to allow wild-card based filtering of what you see in the dialog box. The 'Filter' option makes data selection and management of data easier. This dialog is used by several commands to select layers, blocks, CAD styles, object types and user-created data from the DWG.

Major enhancement: -> CP_TC (CADPower-> Text-> Creation-> Draw Quick Text (running numbers): The Text Counter command has been significantly enhanced. You can now create auto-incrementing text based on real numbers also. If you need to create a text series like 2.1, 2.2, 2.3 and so on, it is now possible using the new feature in the CP_TC command.

The Character incrementing series algorithm also has been completely re-written. You can now create chaaracter series like A, B, C, D.... Z, and continue as Aa, Ab, Ac..... The 'Insert from existing series' and 'Delete from existing series' options have been completely re-written and verified for correctness.

CP_XYZSCL (CADPower -> Miscellaneous -> CAD Procedures -> Scale objects (unequally) in X,Y and Z directions) command has been improved. You now have the 'R-Relative' option to specify scale factors in X and Y direction. The Relative option works like in the SCALE command and allows you to specify (or mouse pick) an old length and a new length, thereby determining the scale to be applied.

The FR, ON, OF, LO and TH short-cut commands that are used to control layer settings now allow you to select multiple objects in the selection. Earlier, it was only possible to select one object and the layer of that object would be turned on/off, frozen or thawed. Now, it is possible to respond with a . character in response to the layer names, and CADPower will present the "Select objects" prompt. This will enable you to select multiple objects and all the layers of these objects will be subjected to the command in operation.

Important Enhancement: All CADPower dialog boxes that ask for generic multiple selection (like layers, block etc) now has a new item called 'Filter' which allows wildcard filtering. This makes it much easier to select from large lists. 

 

Interface changes

----

Bug Fixes
----

CP_DYNATTPLACE (CADPower -> Block Tools -> Place blocks - position attributes interactively): This command was broken and has been fixed.

CP_TXTEVAL (CADPower -> Text -> Display -> Apply arithmetic/statistical operations on text objects): This command was broken and has been fixed.

CP_TXT2ATTDEF (CADPower -> Text -> Conversion -> Convert text strings to attribute definitions): This command was broken and has been fixed.

CP_CHCASE (CADPower -> Text -> Conversion -> Change Case): This command not converting Underlined text into Title case properly this has been fixed.

CP_CONNECTBLOCKS (CADPower -> Blocks -> Block-related -> Connect blocks based on attribute value): If the attribute tag name was incorrectly specified, the command would crash. This has been fixed now. Additionally, you can specify multiple attribute tag names separated by commas. This means that you can now connect multiple attribute names across blocks using this command.S

CP_READEXIF: CADPower Miscellaneous -> File Management -> View / Extract EXIF data: This command was crashing during execution and has been fixed

CP_CHOP : (CADPower -> Miscellaneous -> CAD Procedures -> Object Chopper): The CP_CHOP was not working correctly on closed periodic curves (like CIRCLE and ELLIPSE). This has now been fixed. You can chop a circle and ellipse accurately with this fix in place.

CP_TXTSLIDE  (CADPower -> Text -> Editing -> Slide (move) text relative to its rotation angle) was crashing upon startup. This has been fixed now.

CP_EXTRUDER (CADPower -> Build -> Easy solids extruder) was crashing upon startup. This has been fixed now.

CP_CONS_TXT (CADPower -> Text -> Editing -> Consolidate text into MText/Text): command was crashing upon start. This has now been fixed.

The automatic loading of toolbars during startup of CADPower and GeoTools has been disabled. The feedback we got was that this was annoying and must be removed.

CP_SL (CADPower -> Selection -> Select current Layer): This command was crashing. It has now been fixed.

CP_DIMPREC (BricsCAD+ -> Change Dimension Precision): This command was not working. It has now been fixed. (BricsCAD only)

 

CADPower Tutorial

Lesson 1 - Polyline and Annotation Tools
In this lesson we cover how to utilize polyline tools for converting the polyline from 2D to 3D and assigning 'Z ' values to it.

Lesson 2 - Polyline Editing and Build Tools
In this lesson we cover how to edit 3D polylines and get details using Build Tools.

Lesson 3 - Block and Conversion Tools
In this lesson we cover how to utilize some of the block tools for representing Lots and marking there centroid.

Lesson 4 - Text Tools
In this lesson we cover how to utilize some of the text tools for editing and modifying the text in the drawing.

Lesson 5 - Inquiry Tools
In this lesson we cover how to utilize some of the Inquiry tools for finding out the details of the Lots.

Lesson 6 - Annotation Tools
In this lesson we cover how to utilize some of the Annotation tools for Annotating the polylines.

Lesson 7 - Conversion Tools
In this lesson we cover how to utilize some of the frequently required conversion tools in road development. 

Lesson 8 - Polyline, Block and Text Tools
In this lesson we cover how to utilize some of the Polyline, Block and text tools for working with block attributes.

Lesson 9 - Block Tools for Exporting and Editing Attributes
This tutorial covers how to utilize some of Block tools for Exporting (extracting) and editing block attributes.

Lesson 10 - Block / Attributes Editing and Modifying Tools
This tutorial covers how to utilize some of CADPower Block / Attribute tools to edit, modify the block attributes.

Lesson 11 - Text Tools
This tutorial covers how to utilize some of CADPower Text tools to change case of text, consolidate Text into Mtext and print Date / Stamp

 


Previous : Overview

Table of Contents

Next : Shortcut macros